o v o 9 e v
— - - - — -
@ ° @ ° @ v
v e v o v e
o - e - - —

How to create an email
reporting dashboard with
Google Data Studio
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Intro

Email reporting and analytics can be tricky to navigate. ESP reporting doesn't
always provide specific data or present the data in ways that can be useful, or
easy to digest. The alternative, manually creating email reports can take up to
two working days to create, validate, and present in ways that stakeholders
could understand.

| eventually came across Google Data Studio, and through a couple of years of
experimenting and trial and error, I've found a way of automating email analysis
and saved myself a ton of time.

Additionally, I've been able to create detailed reports for myself, and distilled
versions for stakeholders who don't need to know the nitty-gritty.

‘ TLDR; Google Data Studio can (a) visualise your data (b) give you
more control over your data reporting and (c) automate the entire
process. Boom.

Continue reading to get an in-depth tutorial on how | create an email reporting
dashboard in Google Data Studio. You can follow along with the steps using the
sample documents provided.

Sample documents

https://s3-us-west-2.amazonaws.com/secure.notion-static.com/c3a2a8
ce-f75e-40ff-836f-92c4bd7a32af/SEINO-demo-data.csv

Sample Google Sheet

Sample Google Data Studio report

Requirements

Before you begin, ensure you've got the following:
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e A Google account to be able to access Google Data Studio and Google
Sheets

e An email report exported from your ESP that has the following fields at a
minimum:

e Send date

o Campaign name

e Number of sent emails

e Number of delivered emails
e Number of opens

e Number of clicks

e Number of unsubscribes

Instructions

1. Export your email report from your ESP.

Be sure to export data for all time rather than a small window each time.

2. Import the spreadsheet into a Google Sheet

| Ensure that your spreadsheet doesn't have a 'total' line. If it does, just
delete it.

You can either just copy and paste the entire contents of the sheet, or click File
> Import and upload the file.

3. Go to Google Data Studio, and create a nhew report.

You can click the create button at the top left of the screen or select 'Blank
Report'
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4. Add data to the report.
When prompted, add data to the report. Select '‘Google Sheets'
Select authorise, and then authorise your account.

Then, select the name of the Google sheet that you've just created and click
ADD at the bottom right of the screen.

Data Studio will ask you to confirm to add data to the report, so just go ahead
and click ADD TO REPORT

5. Edit the data source

At this point, you want to make sure that you have the right data to work with in
your report.

Go to Resource > Manage added data sources

This is where you can find the list of data sources added to the current report.
Should you want to add Google Analytics or other sources as part of your email
reporting dashboard, you can find them easily here.

Right now, just click EDIT

6. Create calculated fields for open rates, click rates, click to
open rates and unsubscribe rates.

Most ESPs will also export open rates, click rates and unsubscribe rates, but
it's more accurate to set these fields up as calculated fields.

We'll start off by creating a field for Open Rates
Click + ADD A FIELD at the top of the page.
What you'll see on the page is:

« Available Fields - All of the fields currently available from your Google
Sheet.

How to create an email reporting dashboard with Google Data Studio



o Field Name - Put in 'open rates'. If you already have a field from your
google sheet that has the same name, | would suggest using a naming
convention like 'calculated - open rates' or even 'C-OR' so you'll know
which field to use.

» Field ID - This is generated automatically by Data Studio.

o Formula - This is where you'll put in the formula that will automatically
calculate your open rate.

If you are familiar with Excel or Google Sheets, creating a formula in Data
Studio will be fairly familiar territory to you. The only difference is that instead
of referencing cell numbers, you'll be referencing the Available Fields.

For open rates, this is the formula you'll want to use:

SUM(Open)/SUM(Sent)

The text in the brackets are referring to the Available Fields you have, so they
might be named differently depending on the data you've exported from your
ESP.

Normally | tend to calculate my rates out of emails delivered, rather than sent
but that's out of personal preference.

In the sample data I'm using, the field is called Sent all, so the formula looks like
this:

SUM(Open)/SUM(Sent all)

When you start typing the formula, you will notice that when you type ‘O’ for
example, a menu will pop up prompting you to select the correct available field
to refer to, like the Open Rate field you've created.

Once you have typed that formula, there should be a green tick at the bottom.
That means Data Studio has validated the formula and it will work.

Click UPDATE at the bottom right.

Click to go back to ALL FIELDS at the top left, scroll down and find the field
you've just created. Change the data type it will be from Number to Number >
Percent. This means that this field will be treated as a percentage.
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Repeat so you create fields for click rates, click to open rates and unsubscribe
rates. These are the formulae | use to calculate them:

Click rate

SUM(Clicks)/SUM(Sent)

Using the sample data, this formula will be: SUM(Clicks all)/SUM(Sent all)

Click to open rate

SUM(Clicks)/SUM(Opens)

Using the sample data, this formula will be: SUM(Clicks all)/SUM(Open)

Unsubscribe rate

SUM(Unsubscribe)/SUM(Sent)

Using the sample data, this formula will be: SUM(Unsubscribes)/SUM(Sent
all)

Once you've created the calculated fields you desire, click FINISHED at the top
right.

Depending on the data you have available, you could also create
additional fields to calculate bounce rates, spam rates and other
reporting metrics.

‘ Click here to see other functions available to use in Data Studio.
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7. Set your current page settings

This is to ensure that all of the elements you will create will follow specific
rules, like which data source they are drawing from and which date field is
being used.

Data Settings

Right-click anywhere on the report and select Current page settings.

Click on the box that says Select Data Source and select the Email Report data
source you've just created and edited.

Click on the plus sign under Date Range Dimension and select the Send date
field.

You will notice there is an option to ADD A FILTER. This is where you
can create and use filters to exclude or include data. For example, if
you wanted to exclude any campaigns named 'Test".

Style Settings

This is where you can change how big the report is, and the page background
colour.

I normally go for a screen size of 1920 x 1080 so | know it'll fit most monitors.
You can also choose to pick dimensions that can fit onto a piece of paper
should you want to print your reports out.

8. Start creating report elements

This is where the fun begins. Now that you've prepped your data source, you
can start using the data to create different elements to make up your
dashboard.

To delete anything on the canvas, simply right click on any element and select
Delete.

Everyone's needs are different, but for the sample dashboard I've created, I've
set up some basic elements.

e Monthly summary table
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¢ Monthly chart
e Scorecards

o Campaign performance table

8.a. Creating a monthly summary table
Select Add a chart > Table

Click and drag where you would like to place it on the canvas. You can always
move this chart after you've created it so don't worry about placing it perfectly.

On the right hand menu, you will see two tabs: DATA and STYLE.
DATA is where you will manage which fields will show up in the chart.

STYLE is where you will manage how the data is presented.

Edit the Date Range

Click the box under Date Range Dimension and select Send date. However,
you can leave the box blank and it will default to the page settings you've set
from earlier.

Edit the Dimension

Under Dimension click on the green box and select Send date from the pop-up
menu.

Since this is a monthly summary, you need to aggregate the data so it appears
monthly. Click on the calendar icon next to Send date, and click Date > Date
and Time > Year Month.

You can also change the name of the field in this pop-up menu to say Month
instead of Send date

Edit the metrics

Clear any boxes here by hovering your mouse over them and clicking the 'x'".
Select Add metric and type to search for your Sent field.

You can also search from the list of available fields to the right, and click and
drag them in.
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Keep adding metrics until you have the calculated open rates, click rates, click
to open rates and unsubscribe rates you created earlier.

Edit which data field to sort by

Scroll down the right-hand menu and select which field to sort the table by. |
recommend using the Send Date field.

Edit the style

You can choose to change aesthetic of the table like background and border
colours. This comes in useful if you need to create client reports.

For monthly summary tables, | would:

» Uncheck Table Body > Row numbers. Since you're already sorting by
months, there's no need for these.

e Uncheck Show pagination.

Congrats! You now have a monthly summary table. This is a useful table to see
how your emails have progressed. You could change the send date field to
show weekly instead of monthly, depending on your cadence.

Send date (Year

Month) Sentall v Open rate Clickrate Click to openrate  Unsubscribe rate

Mar 2021 242,974,433 25.09% 2.94% 11.73% 1.5%

8.b. Create a monthly summary chart

The beauty of using a data visualisation tool like Google Data Studio is that you
can look at the same data presented in different ways.

Right-click on the monthly summary table you've just created and click
Duplicate.

On the right-hand menu, click Chart >
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Table and select the Line Chart option. Chart > Table A

And... that's it. Your table is now a chart. @--.; == WP
Under the STYLE tab, you can change the oAbl thihe THE =
colours of each of the metrics if you wish. = (= )
= =60 0
< kit thl Yl 2od 27
=PV - Sl

X

8.c. Create scorecards

Scorecards are incredibly useful to get a snapshot of your metrics.

Click Add a chart > Scorecard

) ) [} Addachart~ 85~ = Addacontrol ~
Click anywhere on the canvas to place it.
Table
On the right-hand menu, clear the Date T=: o= o=
Range Dimension. Scorecard
168 69.3K

Under metric, select Open Rate

Continue the steps above until you've W o~
created scorecards for the calculated

click rates, click to open rates and
unsubscribe rates you created earlier.

You can bulk format all of the scorecards you've created by clicking
shift on your keyboard and selecting the scorecards you want to edit.
Then, go to the STYLE tab on the right-hand menu and adjust the
settings accordingly. This also applies to bulk editing elements.

8.d. Create a campaign performance table

Finally, you'll want to know how your individual campaigns have been doing.
Right-click the monthly summary table and duplicate it.

Edit the Data

Change the Send date dimension to Campaign Name.
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You can drag and drop more metrics into the table such as the number of
emails sent, opens, clicks and unsubscribes.

If you're lucky, your data also includes subject lines which | would recommend
including in this table.

Edit the Style

| would personally adjust the style settings to include row numbers and
pagination.

9. Add data controls

Data controls are exactly what they sound like - elements that can easily help
you filter and control the data on your dashboard.

Date range

It's important to have a date range control, so you _
can look at how your emails did in specific pockets [} Drop-down list

of time.
Fixed-size list

Click on Add a control > Date range control and

click anywhere on your canvas to place it. Al Input box
Under data, you can leave it as Auto date range or ! za  Advanced filter
you can select a default window of time, like last 30 T
41— laer
days. -
Tickbox
D Date range control
4l Data control
e

Campaign name search

If you wanted to look for specific campaigns, you can make it easy by putting in
a search dropdown box.

Click on Add a control > Drop down
list and click anywhere on your
canvas to place it.
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Under Control field select Campaign
hame

= Addacontrol v <> |

~| Drop-down list

10. Formatting and styling the report
Okay, we're at the home stretch here.

You have now got a pretty functional looking report - it's time to put the
finishing touches so you have a data dashboard that can present the
information in an easy-to-digest way.

This is vital - data visualisations are the difference between easily spotting
meaningful trends and a wall of numbers.

Report-level elements

You can create multiple pages for a single report and make the design
consistent by having elements that appear on all of the pages.

| would create a header that has things like branding and data controls as
report-level elements.

To make any element report-level, simply right click on it and select Make
report level

You can also insert shapes to create areas on your canvas by selecting Insert >
Rectangle or Insert > Circle.

Additionally, you can even insert images (Insert > Image) to your report - |
usually pop in a logo.

Heatmaps or bars

You can make any trends based off the metrics in your tables more visually
outstanding by formatting columns to appear as bars or heat maps.

Click on any table and click on the STYLE tab.
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Now scroll down and select what number
column you would like to format.

Metrics

Number

Select the Number dropdown menu, and select
Heat map or Bar/Pub. Heat map = =

You can select either, but | tend to use Bar/Pub Bar/Pub
for clarity.

auto v

Sentall  Open Openrate Clicks all ~Click rate Clicktoopen  Unsubsori Unsubscribe Sentall  Open Openrate  Clicks all CITTIGERNNC L & R e B
787551 276509 3511%MEEM 28116 3.57% 10.17% 0 9844 1.25% M 787551 276500 |G| 28116 3.57% 1017% 9844 1.25%
113530 15690 13.82%M 3054 2.69% 19.46% I 1,646 1.45% M 113530 15690 1382% 3054 2.69% 19.46% 1,646 1.45%
419487 118715  28.3%M 16,066 3.83% 13.53% W 5244  1.25%M 419487 118715 “ 16,066 3.83% 13.53% 5244 1.25%
957,602 112901  11.79%M 46061  4.81% 40.8% 15226 1.59% 957,602 112,901 1179% 46061 481% 40.8% 15226 1.59%
270526 69255  25.6%M 6953  2.57% 10.04% 0 3355 1.24% 270526 69,255 25:6% 6,953 ek s 3355 1233
760312 220490 29% 26383 3.47% 11.97%0 12,697 1.67% 760312 220490 || 00%| 26383 HOT R 12697 i
177884 23979 13.48%M 2935 1.65% 12.24% 0 3095  1.74% M 177884 23979 2% 1.65% 2 174%
36378 14,103 39.02% N 1415 3.89% 9.97%0 727 2% 36373 14193 _ 1415 8555 o 727

111781 16611 14.86%M 2347 21% 14.13% M 2157 1.93% M— e e . 2% EE> HER 2157 [ 198
278192 98146  35.28%ME 4896 1.76% 4.99%] 3700 1.33%m wars2  ss1eo [NNNNGERRR] 400 1.76% 499% 3700 133%
408702 55951 13.69%M 16348 4% 29.22% 7,602 1.86% M- 408702 55951 e % 2922% 7602

762330 285264 [NSTHER| 10063 132% 353% 12274 1.61%
762330 285264 37.42%MEEM 10063 132% 3.53%] 12274 1.61% M

476457 156183 [N Gamn|  7.004 1.47% 4.48% 6813 1.43%
476457 156,183  32.78% M 7004 1.47% 4.48%] 6813 1.43% M

284,582 74,703 26.25% 8,281 291% 11.09% 3,842 1.35%
284582 74703 26.25%mM 8281 291% 11.09% 1 3842 135% MMM

242,974,433 60,968,... 25.00% 7,153,524 2.94% 11.73% 3,638,250 1.5%
242,974,433 60,968,.. 25.09% 7,153,524 2.94% 1.73% 3638250 1.5%

A table with bars A table with heat maps

Colour scheme

You'll probably notice above that each of the columns is a different colour. |
tend to match these colours across the whole data dashboard so that the rates
are always represented by the same colours. For example, open rates are
always magenta no matter which element in the table they are in.

Open rate Send date

: Click to open Unsubscribe
2 5 O 9 % (Year Month) Sentall Open rate Click rate rate rate
. ] v
Mar 2021 242974433  25.09% M  2.94% 11.73% 0 1.5%
11.73% 1.50%
Grand total 242,974,433 25.09% 2.94% 11.73% 1.5%

This reduces the cognitive load when you're trying to decipher your email
performance and makes it a lot easier for stakeholders to wrap their heads
around the data.
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You can always choose colours that match your branding requirements, but be
sure to use colours that are distinct from each other.

11. Updating your report

This way of using Google Sheets and Data Studio are specifically designed if
you have no way of syncing up your ESP's reporting data and have been doing
your reporting manually.

To update your report, just export the data for all time from your ESP on a
regular basis and replace all of the data in the Google Sheet that you are using
as a data source. This usually takes me just a few minutes at the beginning of
every week.

As long as the columns are exactly the same, this will mean that the data will
be automatically and accurately updated in your Data Studio report since you
have already done the hard work of creating the calculated fields.

12. Sharing your report
You are now ready to share your report with your teammates or clients.

Simply select Share at the top right of the page and add people by email
address to view the report. Alternatively, you can click Manage access to
make the report viewable by anyone who has the link.

I've done this with my sample report here >
https://datastudio.google.com/reporting/c03801dd-e707-4ca6-alfe-
11daad8d390c

Wrapping up

Time, as any marketer knows, is a precious resource and while trying to
understand Google Data Studio can initially be a challenge, | guarantee that
investing the time to gain practical knowledge in the platform can mean a
massive return in future. And hopefully, this resource is one of the stepping
stones to get you there.

Naturally there may have been some things | have missed so just let me know
(email, twitter) if there's anything | should go into more detail about, or whether
there are other elements of email analytics and Google Data Studio you'd like
to know about!

Back to NajmahSalam.com
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Written by Najmah Salam

Email | Website | Twitter | LinkedIn

Special thanks to SEING | Email Analytics for providing the sample
data.
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